What should I do if the internet light is off or there is an error message “ WAN Port Unplugged” on the TP-Link router page?

Troubleshooting
Updated 07-06-2023 00:30:10 AM 270196
This Article Applies to: 

Note: Refer to this FAQ if the router's other LEDs are malfunctioning in addition to the Internet LED.

What should I do if the LED of the TP-Link router is abnormal?

 

Please first verify that the cable is detected by your router. If the internet light on your router is off or there are any error messages on the TP-Link router's web interface, such as "WAN Port unplugged" or "something wrong with the hardware connection", refer to How to distinguish the RJ45&RJ11?

 

If your cable is appropriate for your router, please use the following steps for troubleshooting:

Step 1: Verify that the modem is properly connected to the router's internet/WAN port. If you are experiencing issues, it is recommended to always try a new CAT5E or higher Ethernet Cable.

 

Step 2. Ensure that your Modem is working properly by connecting a wired device/PC to your modem and seeing if it can connect to the internet. You may also try to set up an older router to see if it can detect the WAN connection

  • If other devices, like computers, can’t recognize the modem, the modem is most likely the cause of the problem. We advise you to get in touch with the modem's support staff, oftentimes this will be your ISP.
  • When other devices can recognize the modem, and for the routers which have separate internet LED, please go to Step 3.

For the routers like the Archer AX3200/AX11000/AX6000/C5400 etc which have only one LED Indicator but their web interface displays the error "WAN Port unplugged" or "Something Is Wrong with the Hardware Connection", please go to Step 4.

 

Step 3. Disconnect the modem from the router, then attach the same Ethernet wire from the router's WAN port to one of its LAN ports, and check to see if the router's Ethernet and internet lights are on.

  • If the router's internet and Ethernet lights are both OFF it is possible that:

The WAN port of the router may be faulty, or,

The Ethernet cable may have a problem

Suggestion:

Use a Different Ethernet Cable and Retest the Connections

Contact the TP-Link support team to get further assistance.

 

  • If the router's internet and Ethernet lights are both ON, it is possible that:

Possible Reason:

The router is failing to negotiate speed with the modem correctly. Go to Step 4.

 

Step 4. Connect the modem back to the WAN port of the router, as you normally would, and log into the web interface of the TP-Link router. Under Advanced > Internet > “Internet Port Negotiation Speed Setting”, force the internet port negotiated speed to 100Mbps full duplex, and see whether the internet LED comes on.

How do I log into the web-based Utility (Management Page) of TP-Link wireless router?

We take Archer AX1500 as an example.

If the internet light on the router is still off, please contact the TP-Link support team with the following information.

The model number of the modem

Your internet service provider's name

The model number, hardware, and firmware version of the TP-Link Router

Results of each troubleshooting step

Related FAQs

Looking for More

Is this faq useful?

Your feedback helps improve this site.

Recommend Products

Community

TP-Link Community

Still need help? Search for answers, ask questions, and get help from TP-Link experts and other users around the world.

Visit the Community >