Abnormal LED lights and bad ports on the TP-Link Deco

Troubleshooting
Updated 10-20-2022 02:44:42 AM 14028
This Article Applies to: 

This article introduces some common hardware issues of Deco and what troubleshoot you can do.

Case 1. No LED lit up on the Deco

1) Try to connect different power socket and different power adapter to the Deco, if the LED lit up when use different power adapter or power socket, it means the problem is on the socket or adapter.

2) Confirm the power cable is plugged into Deco tightly.

After tried above troubleshooting, if the LED still not lit up, it should be a hardware issue of the Deco. And it’s suggested to contact TP-Link support via e-mail to confirm if your Deco is still under the warranty.

Note: If all of your Deco units have no LED lit up, please confirm whether you enabled LED or LED Off Time on the Deco app (On the Deco app, go to More->LED control to check).

Case 2. LED is solid yellow

Press the bottom reset button for 1 second to reset the Deco, wait for 2 minutes, and then check the LED status.

If LED is flashing blue, you can refer to the link to configure the Deco again.

If the LED is still solid yellow all the time, it should be a hardware issue of the Deco. And it’s suggested to contact TP-Link support via e-mail to confirm if your Deco is still under the warranty.

Case 3. LED status is red

For this troubleshoot tips, please refer to the Case 2: LED is solid yellow.

Case 4. Bad port on the Deco

For example, the Wi-Fi network of Deco is working, however, when connect a PC to the Deco by an Ethernet cable, PC shows cable is unplugged.

For this issue, please refer to the following troubleshoot tips.

1. Disconnect the PC and Deco, then connect PC to the modem directly with the same Ethernet cable, confirm if PC and the Ethernet cable are working.

2. If PC still shows no Ethernet cable plugged in, it should be the Ethernet port on the PC or the Ethernet cable has issue.

3. Try a different Ethernet cable, try a different PC

4. If the PC and Ethernet cable are working properly, using different ports on the Deco for a try.

After you try all the above troubleshooting, and if it’s the port issue of Deco, it’s suggested to contact TP-Link support via e-mail to confirm if your Deco is still under the warranty.

Note: When contact the TP-Link support, please provide the S/N on the Deco/on the box and the picture of the invoice.

Related FAQs

Esta FAQ é útil?

Your feedback helps improve this site.

Recommend Products

From United States?

Get products, events and services for your region.