Fail to setup the Satellite Deco

When You Set Up
Updated 07-10-2020 03:39:46 AM
This Article Applies to: 

We may encounter one of the following problems, or error code appears during basic configuration of Satellite Deco, when you have the problems, you can refer to the below suggestions to do some troubleshooting.

Before we configure the Satellite Deco, please confirm your phone is connected to the existing Deco Wi-Fi network.

LED on the Satellite Deco is abnormal

1. LED is not pulsing blue

Note: LED on the Deco M3W is solid white.

Find the RESET button at the bottom of the Deco, press it for one second and then release, the LED will turn yellow, then wait for 2 minutes till the LED turns pulsing blue.

 

2. LED is off

Change another power adapter and power socket to have a try. It could be an issue of the Deco unit, the power adapter or the power socket.

 

Select a model of the Satellite Deco

1. Do not have the option “DECOS”.

In this case, please ensure you are log into the Deco app with the owner account. If you log in to the Deco app with the manager account, you are unable to add/remove any Deco unit.

 

2. Failed to connect to XXX (The Wi-Fi name of the Deco network).

1) Disable the VPN program on the phone if there is one.

If you have a VPN connection running on your phone, please disable it temporarily during configuring the Satellite Deco as it will block the communication between the phone and the Deco network.

Some security applications such as Lookout and AdGuard, are working based on VPN as well. In this case, you will need to force to close these applications to avoid any possible problems.

2) Update the Deco app to the latest version.

3) Ensure the phone is connected to the Wi-Fi network of the main Deco.

4) Try on a different phone.

 

Get stuck on “Looking for new deco”

Error Code: We couldn’t find deco

1. Move your smartphone closer to the Satellite Deco unit you're trying to add, move the Satellite Deco unit next to the Main Deco, reboot the Main Deco.

Make sure the Satellite Deco unit is powered on and the LED is pulsing blue. If not, reset the Satellite Deco by pressing the RESET button for one second.

Then wait for 2 minutes till the main Deco is working and the LED is pulsing blue on the Satellite Deco, try to add the Satellite Deco again.

2. Make sure you selected the correct model when configuring the Satellite Deco.

3. Connect the Satellite Deco unit to the Main Deco by an Ethernet cable, then try to add the Satellite Deco again.

4. For Deco M5, P7, and Deco M9 Plus only:

Force the Deco app to close, then open the app and add the Satellite Deco again. If the app reminds "We couldn't find Deco", please tap TRY AGAIN. Then you may see an option called "Setup via Bluetooth", tap the option and walk through the steps to complete the setup (disconnect any Bluetooth devices connected to the phone in this case).

5. Unplug main Deco with the modem, connect the Satellite Deco instead, refer to the link to create a new Deco network for the Satellite Deco, after setup the Satellite Deco successfully, update the firmware of the Satellite Deco to the latest version, then reset the Satellite deco, and add it to the existing Deco network.

For Deco M3W, please refer to the following steps to troubleshoot.

1. Put the smartphone, Deco M3W, and the main Deco together, restart the Main Deco, and wait for 2 minutes. When main Deco works properly, add the M3W unit again.

2. Reset Deco M3W and reconfigure it (Find the RESET button on the side of the Deco M3W, press it for one second and then release).

3. Make sure you select the correct model when configuring M3W.

 

Get stuck on “Testing connection/optimizing the network”.

1. Reset the Satellite Deco (find the RESET button at the bottom of the Deco, press it for one second and then release), disconnect main Deco from modem, power off and on both main Deco and modem, wait a few minutes till modem completes reboot.

Then connect Satellite Deco to Main Deco via Ethernet cable, and connect main Deco back to modem via Ethernet cable, configure the Satellite Deco again.

2. Unplug main Deco, connect Satellite Deco to the modem instead. Refer to the link to create a new Deco network for the Satellite Deco, if it succeeds, reset the previous main Deco and add it to the new Deco network.

For Deco M3W, please refer to the following steps to troubleshoot.

1.Reset Deco M3W (Find the RESET button on the side of the Deco M3W, press it for one second and then release).

2.Disconnect main Deco from modem, power off both main Deco and modem and then turn them back on, wait a few minutes till the modem completes reboot.

3.Reconfigure the Deco M3W.

 

For Deco X20/X60

If you fail to add the Deco X20/X60 Satellite units which are in the same package as the main Deco, please refer to the following troubleshooting steps. Otherwise, please refer to the above troubleshooting steps.

Normally, if the Deco X20/X60 Satellite units and the main unit come from the same package, they will be added automatically to the Deco network within 2 minutes after you power them on.

If you fail to add the Deco X20/X60 Satellite units, please connect the Satellite unit to the main Deco by an Ethernet cable, and then update the firmware of the Satellite unit through the Deco app. After the update, you can remove the cable and the Satellite unit will connect to the main Deco wirelessly as expected.

 

If above suggestions are not working, it’s suggested to contact TP-Link support.

 

Sign Up for News & OffersTP-Link takes your privacy seriously. For further details on TP-Link's privacy practices, see TP-Link's Privacy Policy.