What can I do if I can’t find my Tapo camera on Tapo APP?

Troubleshooting
Updated 11-07-2023 11:23:57 AM 97379
This Article Applies to: 

If your device does not appear on your app after completing the configuration process, please try the following troubleshooting suggestions:

1. If you are using a Wi-Fi wireless configuration to connect your camera, please check if the camera has successfully connected to the router. You can verify whether the camera is connected to Wi-Fi by checking the System light of your camera. For most Tapo Cams, if it is not connected properly, the LED light will blink red slowly. For the HomeKit version Camera, its LED light indicator will blink blue slowly. If the camera cannot connect properly, we recommend resetting the camera to factory default settings as per the User Guide and then reconfiguring the camera.

How to reset my Tapo camera

2. Check the DHCP settings on your router and ensure that the DHCP Server of your router is enabled. If the camera has already connected to the router properly, you will see the device in the client list of your router. If you don’t know how to do this, please contact your router’s customer support.

3. Please verify if there are any special symbols in your Tapo accountTP-Link ID password. If there are, try to remove them and make the account password simpler by only using numbers and English letters. Then reset and add the camera from the beginning again.

4. Connect your smartphone to the same Wi-Fi network as your camera and check whether you can see it on the Tapo app. If you can see it, that means the camera fails to connect to the cloud for unknown reasons and you cannot access it remotely. In this case, verify if any firewall or security settings are blocking the connection to the Cloud Server. Temporarily disable any antivirus, firewall, or security software to see if it resolves the issue.

5. Using a public DNS server may improve the connection, try changing your router's DNS server settings to 8.8.8.8. If you don't know how to do this, please contact your router's customer support.

To eliminate potential issues with the router's Wi-Fi network, it is recommended to use a mobile hotspot and configure the Camera to test its functionality.

Here are steps for using a mobile hotspot to test the Camera's configuration:

Preparation: We suggest having two phones. Use one phone (Phone A) to create a hotspot and use another phone (Phone B) to download the Tapo app and complete the setup process.

Steps:

1. On Phone A, disable Wi-Fi and enable only mobile data.

2. On Phone A, navigate to phone settings and access the "Personal Hotspot" or "Mobile Hotspot" option, ensuring that the "Mobile Hotspot" feature is activated. Please make sure the created hotspot operates on a 2.4GHz network.

3. Set a unique name and password for the hotspot, different from your router's Wi-Fi, to facilitate the Camera's connection.

4. On Phone B, download the Tapo app. Follow the app's instructions to add the device and complete the remaining setup steps as guided by the app.

Please contact TP-Link technical support with the following information if the issue persists after the above suggestions.

1) Your TP-Link ID or cloud account.

2) The model number of your TP-Link Cam and its MAC address.

3) The model number of the host router.

4) Whether you have tried all the suggestions listed above or not. If yes, what are the results?

Related FAQs

Looking for More

Is this faq useful?

Your feedback helps improve this site.

Recommend Products

Setup Videos

Tapo Smart Camera Unboxing and Configuration Video

Community

TP-Link Community

Still need help? Search for answers, ask questions, and get help from TP-Link experts and other users around the world.

Visit the Community >

From United States?

Get products, events and services for your region.