TpPLC Utility Not Detecting Powerline devices

Troubleshooting
Updated 04-28-2022 11:02:55 AM 12449
This Article Applies to: 

If the Powerline units are working perfectly but they are not coming up in the TpPLC utility, you may try the following troubleshooting.

1. Ensure the computer installed tpPLC Utility and powerline devices are working in the same network so that they could communicate with each other.

2. Connect your computer to the powerline unit directly via Ethernet cable or Wireless (unplug other powerline units), e.g. TL-PA8010P—computer.

3. Download and try the latest tpPLC Utility, you may refer to this FAQ: How to prepare for using the tpPLC Utility (new logo)?

4. Try the old version of the tpPLC Utility that has better compatibility with powerline units: https://static.tp-link.com/2019/201901/20190118/tpPLC_Utility_Windows.zip.

5. Turn off Firewall settings or Anti-virus software on your computer.

6. Turn off VPN software.

7. Try a different computer/laptop.


If the issue still persists, please help provide the following information and contact support.

1. Model of powerline device and its firmware and hardware version

2. Operation system of your computer

3. Version of tpPLC Utility that you have tested

4.The network topology e.g. Router <Ethernet> TL-PA8010P #1 ___powerline __ TL-PA800P #2-<Ethernet> PC (tpPLC Utility)

Related FAQs

Looking for More

Is this faq useful?

Your feedback helps improve this site.

Recommend Products

SubscriptionTP-Link takes your privacy seriously. For further details on TP-Link's privacy practices, see TP-Link's Privacy Policy.

From United States?

Get products, events and services for your region.