Omada Switches RIP Configuration Guide

Configuration Guide
Updated 05-30-2024 11:00:03 AM 1815
This Article Applies to: 

This article applies to:

Omada Software Controller V5.9 and above

OC200(UN)_V1_1.24.0 Build 20230328 and above

OC200(UN)_V2_2.9.3 Build 20230328 and above

OC300(UN)_V1_1.17.0 Build 20230328 and above

OC400(UN): All firmware versions

SX6632YF/ SG6654X/ SG6654XHP/ SG6428X/ SG6428XHP: All firmware versions

This guide introduces how to configure the RIP feature on Omada switches. In Controller mode, GUI for RIP is currently not supported, and you can configure the RIP feature via the CLI Configuration module. In Standalone mode, configure the settings via the device’s GUI.

Overview of RIP

RIP (Routing Information Protocol) is an Interior Gateway Protocol (IGP) based on the Distance-Vector algorithm. It uses UDP packets for the exchange of routing information via port 520.

RIP is a distance-vector protocol that uses hop count as its metric. Compared to OSPF, RIP does not have the precise path calculation capabilities. In large networks, OSPF performs better and is more scalable. Therefore, RIP is mainly used in smaller networks, such as campus networks or simpler regional networks.

However, OSPF configuration and management are complex, requiring professional networking knowledge and skills. It also generates and updates a large amount of routing information, consuming a lot of network bandwidth and processing resources. RIP, compared to OSPF, has a smaller amount of calculation and update and has less impact on network load.

RIP is an Interior Gateway Protocol (IGP) running in the autonomous system. Currently, there are two versions of IPv4 RIP: RIP Version 1 and RIP Version 2. Omada switches use RIP Version 2 by default, which can receive routes from both RIP-1 and RIP-2. The version can be changed using the CLI commands.

Main functions of RIP:

1. Auto maintain the network routing information: RIP updates and maintains Routing Information Base (RIB) and Forwarding Information Base (FIB) based on the received RIB information from neighboring routers.

2. Fast rerouting: When there are multiple paths to reach a destination network, primary and backup paths can be configured. When the primary path fails, the routing can quickly switch to the backup path, ensuring a stable network connection. This can also be achieved through integration with Bidirectional Forwarding Detection (BFD). Omada switches currently do not support BFD or fast rerouting.

RIP only runs within the autonomous system, while Exterior Gateway Protocols (EGPs) are used between autonomous systems. Within the same autonomous system, multiple IGPs can coexist, and RIP can introduce routing information from other IGPs, such as OSPF routes.

In the routing table, routes generated by different protocols or directly connected routes have different priorities. When multiple protocol routes exist, the routing table is updated based on the default or manually configured priorities (lower numbers indicate higher priority). The default priority is as follows:

Configuration

In global mode, enable RIP using the "router rip" command. Parameters for the RIP protocol should be configured according to the specific scenario. On Omada switches, you can configure RIP in both Standalone and Controller modes. In Controller mode, GUI for RIP is currently not supported, and you can configure the RIP feature via the CLI Configuration module.

Note: When disabling RIP, the related RIP configurations will be cleared. The configurations only take effect when RIP is enabled.

The configuration can be divided into the following three parts:

(1) Basic configuration: Enable RIP on specific network segments. Other configurations can be chosen based on the scenario.

(2) Route Summary: If there are multiple contiguous network segments in the routing table, they can be aggregated into a single route using route summary, reducing the number of routing entries and RIP advertisements.

(3) Introducing external routes: RIP can introduce routes generated by other routing protocols and advertise them to neighboring routers, depending on the priority of different protocols.

1. Basic Configuration

The configuration is based on the following topology. Enable RIP on all network segments of Switch A and Switch B, and establish network connectivity using RIP-2:

1.1 In Controller Mode

Go to the Controller’s CLI Configuration module, and use the following CLI commands to enable RIP on Switch A and Switch B.

Switch A:


router rip

network 1.1.1.1

network 5.1.1.1


Switch B:

router rip

network 1.1.1.2

network 7.1.1.1

network 8.1.1.1

1.2 In Standalone Mode (taking Switch A as an example)

Log in to Switch A’s GUI, go to L3 FEAURES > RIP, enable RIP Protocol, and click Apply. Leave parameters in the Global Config section as default.

Go to Network Config > RIP Network List, and add network segments on which RIP needs to be enabled.

Refer to the configuration above to configure Switch B add VLAN 100/101/102.

1.3 Test

After completing the configuration, log in to the switch via SSH to check the routing table. If Switch A's routing table includes the routes 7.1.1.0/24 and 8.1.1.0/24 obtained successfully via RIP from Switch B, it indicates that the RIP configuration is correct.

Switch B’s routing table:

(Optional, this is only for Controller mode) For an interface that has RIP enabled, you can configure its working status so that it only receives RIP packets but does not send RIP packets. Taking the topology above as an example, to configure the interface 1.1.1.1/24 on Switch A as a passive interface, use the following commands:

router rip

passive-interface interface vlan 100

After running the commands, check Switch A’s and Switch B’s routing table, and you can see Switch B has not received routing information from 5.1.1.0/24 while Switch A has received all RIP routing information from Switch B.

2. Route Summary

Route summary refers to aggregating routes for multiple contiguous subnets in the same physical network into one route. For example, there are three routing entries, 10.1.1.0/24, 10.1.2.0/24 and 10.1.3.0/24. They can be configured to aggregate into one route entry 10.1.0.0/16, and the neighboring routers will only receive the routing entry, thus reducing the size of the routing table and network traffic. By configuring route aggregation, you can improve the scalability of the network and the processing speed of the router. When RIP-2 aggregates multiple routes into one route, the Metric value of the aggregated route will be the minimum value of the metric of all routes.

(1) Enable RIP on all network segments of Switch A and Switch B, and establish network connectivity using RIP-2.

(2) Enable Auto Summary on Switch B.

2.1 In Controller Mode

Refer to previous section 1.1 to enable RIP. Run the following commands to enable Auto Summary on Switch B.

router rip

auto-summary

2.2 In Standalone Mode

Log in to Switch B’s GUI, go to RIP > L3 FEATURES, enable RIP Protocol, and in the Global Config section, enable Auto Summary, then click Apply.

2.3 Test

Before enabling Auto Summary, Switch A receives three RIP routing entries.

After enabling Auto Summary, Switch A receives one RIP routing entry.

3. Introducing External Routes

If the router is running not only RIP but also other routing protocols such as OSPF, IS-IS, BGP, static routes, or directly connected routes, you can configure RIP to introduce routes generated by these protocols. Omada switches currently only support introducing OSPF, static routes, and directly connected routes. When introducing external routes, if no metric value is specified, a default metric value will be assigned.

The configuration is based on the following topology. Configure VLAN 100 interface on Switch A and VLAN 100/101/102/103 interfaces on Switch B and enable RIP. Refer to the CLI commands provided in the previous section 1.1 for configuration details.

Because RIP is not enabled on the VLAN 101/102 interface of Switch A, the routing information from Switch A is not forwarded to Switch B via RIP.

3.1 In Controller Mode

Run the following commands on Switch A to enable VLAN 100 interface on Switch A to introduce directly connected routes via RIP and configure the added metric value as 3:

router rip

redistribute connected metric 3

3.2 In Standalone Mode

After enabling RIP on the corresponding subnets on Switch A and Switch B, log in to Switch A’s GUI, go to RIP > L3 FEATURES > Rout Redistribution, click Add, configure the route type and added metric value, and then click Create.

Check the routing table of Switch B again and you can see that 5.1.1.0/24 and 6.1.1.1.0/24, which do not have RIP enabled, have been added to the routing table and the metric has increased by 3.

4. QA/FAQ

Q1. What Are Differences Between the Default Version of RIP, RIP Version 1, and RIP Version 2?

A: Version 1: The protocol stack can send and receive only RIP version 1 packets by broadcast.

Version 2: The protocol stack can receive RIP version 1 and RIP version 2 packets, but can send only RIP version 2 packets by multicast or broadcast.

Q2. Advantages of RIP-2 compared to RIP-1

A: Routing Information Protocol version 2 (RIP-2) supports the tagging of external routes and uses the routing policy to flexibly control routes based on the tag.

RIP-2 packets contain mask information and support route aggregation and Classless Inter-domain Routing (CIDR).

RIP-2 supports specifying the next hop so that the optimal next-hop address can be specified on the broadcast network.

RIP-2 supports sending update packets for multicast routes. Only devices that support RIP-2 can receive RIP-2 packets. This reduces resource consumption.

RIP-2 provides two packet authentication modes, namely, plain text authentication and message digest algorithm 5 (MD5) authentication, to enhance security.

Q3. Can we use RIP over GRE Tunnel?

A. Yes, GRE can be used as carrier tunnel for RIP protocol packets, all normal protocol activities can be run over GRE tunnels.

Is this faq useful?

Your feedback helps improve this site.

Recommend Products

Community

TP-Link Community

Still need help? Search for answers, ask questions, and get help from TP-Link experts and other users around the world.

Visit the Community >

From United States?

Get products, events and services for your region.