How to configure RIP on Omada L3 Switches via Omada Controller

Configuration Guide
Updated 06-26-2024 07:34:35 AM 3049
This Article Applies to: 

Contents

Objective

Requirements

Introduction

RIP Basic Configuration

Route Summary Configuration

Route Redistribution Configuration

Verification

Conclusion

FAQ

Objective

This guide introduces how to configure the RIP feature on Omada L3 switches via Omada Controller.

Requirements

  • Omada Controller (Software Controller / Hardware Controller / Cloud Based Controller, v5.9 and above)
  • Omada L3 Switches

Introduction

RIP is a distance-vector protocol that uses hop count as its metric. Compared to OSPF, RIP does not have the precise path calculation capabilities. In large networks, OSPF performs better and is more scalable. Therefore, RIP is mainly used in smaller networks, such as campus networks or simpler regional networks.

However, OSPF configuration and management are complex, requiring professional networking knowledge and skills. It also generates and updates a large amount of routing information, consuming a lot of network bandwidth and processing resources. RIP, compared to OSPF, has a smaller amount of calculation and update and has less impact on network load.

RIP is an Interior Gateway Protocol (IGP) running in the autonomous system.

Main functions of RIP:

  • Auto maintain the network routing information: RIP updates and maintains Routing Information Base (RIB) and Forwarding Information Base (FIB) based on the received RIB information from neighboring routers.
  • Fast rerouting: When there are multiple paths to reach a destination network, primary and backup paths can be configured. When the primary path fails, the routing can quickly switch to the backup path, ensuring a stable network connection. This can also be achieved through integration with Bidirectional Forwarding Detection (BFD). Omada switches currently do not support BFD or fast rerouting.

RIP only runs within the autonomous system, while Exterior Gateway Protocols (EGPs) are used between autonomous systems. Within the same autonomous system, multiple IGPs can coexist, and RIP can introduce routing information from other IGPs, such as OSPF routes.

In the routing table, routes generated by different protocols or directly connected routes have different priorities. When multiple protocol routes exist, the routing table is updated based on the default or manually configured priorities (lower numbers indicate higher priority). The default priority is as follows:

On Omada Controller, GUI configuration for RIP is not supported, and you need to configure RIP via the CLI Configuration module.

Note: When disabling RIP, the related RIP configurations will be cleared. The configurations only take effect when RIP is enabled.

The configuration can be divided into the following three parts:

  • Basic configuration: Enable RIP on specific network segments. Other configurations can be chosen based on the scenario.
  • Route Summary: If there are multiple contiguous network segments in the routing table, they can be aggregated into a single route using route summary, reducing the number of routing entries and RIP advertisements.
  • Route redistribution: RIP can redistribute routes generated by other routing protocols and advertise them to neighboring routers, depending on the priority of different protocols.

RIP Basic Configuration

As shown in topology, the requirements of this scenario is to enable RIPv2 on all interfaces on Switch A and Switch B.

VLAN interface configurations of Switch A & Switch B as follows:

Switch A

Switch B

VLAN interface 100: 1.1.1.1/24

VLAN interface 100: 1.1.1.2/24

VLAN interface 102: 5.1.1.1/24

VLAN interface 101: 7.1.1.1/24

VLAN interface 102: 8.1.1.1/24

Step 1. Log in to the Controller via web browser, go to Site Settings > CLI configuration > Device CLI. Then click Create New Device CLI Profile to add the CLI template for devices.

Step 2. Create CLI template for Switch A as the following:

router rip

network 1.1.1.1

network 5.1.1.1

Then click Next, and choose Switch A.

Step 3. Create CLI template for Switch B as the following:

router rip

network 1.1.1.2

network 7.1.1.1

network 8.1.1.1

Then click Next, and choose Switch B.

Route Summary Configuration

Route summary refers to aggregating routes for multiple contiguous subnets in the same physical network into one route. For example, there are three routing entries, 10.1.1.0/24, 10.1.2.0/24 and 10.1.3.0/24. They can be configured to aggregate into one route entry 10.1.0.0/16, and the neighboring routers will only receive the routing entry, thus reducing the size of the routing table and network traffic. By configuring route aggregation, you can improve the scalability of the network and the processing speed of the router. When RIP-2 aggregates multiple routes into one route, the Metric value of the aggregated route will be the minimum value of the metric of all routes.

VLAN interface configurations of Switch A & Switch B as follows:

Switch A

Switch B

VLAN100 interface: 1.1.1.1/24

VLAN100 interface: 1.1.1.2/24

VLAN101 interface: 5.1.1.1/24

VLAN101 interface: 10.1.1.1/24

VLAN102 interface: 6.1.1.1/24

VLAN102 interface: 10.1.2.1/24

VLAN103 interface: 10.1.3.1/24

Step 1. Enable RIP on all network segments of Switch A and Switch B, Please refer to previous section.

Step 2. Go to Site Settings > CLI configuration > Device CLI. Run the following commands to enable Auto Summary on Switch B.

router rip

auto-summary

Then click Next, and choose Switch B.

Route Redistribution Configuration

If the router is running not only RIP but also other routing protocols such as OSPF, IS-IS, BGP, static routes, or directly connected routes, you can configure RIP to introduce routes generated by these protocols. Omada switches currently support redistributing OSPF, static routes, and directly connected routes only. When redistributing external routes, if no metric value is specified, a default metric value will be assigned, the configuration is based on the following topology.

VLAN interface configurations of Switch A & Switch B as follows:

Switch A

Switch B

VLAN100 interface: 1.1.1.1/24

VLAN100 interface: 1.1.1.2/24

VLAN101 interface: 5.1.1.1/24

VLAN101 interface: 10.1.1.1/24

VLAN102 interface: 6.1.1.1/24

VLAN102 interface: 10.1.2.1/24

VLAN103 interface: 10.1.3.1/24

Step 1. Enable RIP of VLAN 100 interface on Switch A and VLAN 100/101/102/103 interfaces on Switch B. Please refer to the CLI commands provided in the first section configuration details.

Step 2. Go to Site Settings > CLI configuration > Device CLI. Run the following commands on Switch A to enable VLAN 100 interface on Switch A to redistribute directly connected routes via RIP and configure the added metric value as 3.

router rip

redistribute connected metric 3

Then click Next, and choose Switch B

Verification

Verification of RIP Basic Configuration

Step 1. Go to Tools>Terminal, select Switch as Device Type, and choose Switch A and Switch B as Sources. Then click Open Terminal to connect to Switch A and Switch B via SSH. You could switch SSH terminals of different switches by Device List.

Step 2. Input following commands to Switch A and Switch B terminals to check the routing information. If Switch A and Switch B obtain the routes successfully via RIP from each other, it indicates that the RIP configuration is correct.

en

show ip route

Switch B’s routing table:

Verification of Route Summary Configuration

Step1. Refer to last section to open terminals of Switch A and Switch B

Step2. Check the routing entries of Switch A before enabling Auto Summary.

Step3. Check the routing entries of Switch A after enabling Auto Summary.

Verification of Route Redistribution Configuration

Step1. Check the routing information of Switch B before enabling Route Redistribution.

Because RIP is not enabled on the VLAN 101/102 interface of Switch A, the routing information of VLAN 101/102 on Switch A is not forwarded to Switch B via RIP.

Step2. Check the routing table of Switch B again after enabling Route Redistribution.

5.1.1.0/24 and 6.1.1.1.0/24, which do not have RIP enabled, have been added to the routing table and the metric has increased by 3.

Conclusion

The above is the configuration guide for how to configure RIP on Omada L3 Swtiches via Omada Controller.

Get to know more details of each function and configuration please go to Download Center to download the manual of your product.

FAQ

1. What are differences between the default version of RIP, RIP version 1, and RIP version 2?

Re: Version 1 can send and receive only RIP version 1 packets by broadcast. Version 2 can receive RIP version 1 and RIP version 2 packets, but can send only RIP version 2 packets by multicast or broadcast.

2. What are the advantages of RIP-2 compared to RIP-1?

Re:

  • Routing Information Protocol version 2 (RIP-2) supports the tagging of external routes and uses the routing policy to flexibly control routes based on the tag.
  • RIP-2 packets contain mask information and support route aggregation and Classless Inter-domain Routing (CIDR).
  • RIP-2 supports specifying the next hop so that the optimal next-hop address can be specified on the broadcast network.
  • RIP-2 supports sending update packets for multicast routes. Only devices that support RIP-2 can receive RIP-2 packets. This reduces resource consumption.
  • RIP-2 provides two packet authentication modes, namely, plain text authentication and message digest algorithm 5 (MD5) authentication, to enhance security.

3. Can we use RIP over GRE tunnel?

Re: Yes, GRE can be used as carrier tunnel for RIP protocol packets, all normal protocol activities can be run over GRE tunnels.

Questa faq è utile?

Your feedback helps improve this site.

Recommend Products

From United States?

Get products, events and services for your region.