Como instalar o controlador Omoada SDN no sistema Linux (acima do Controller 4.1.5)

Configuration Guide
Updated 08-07-2020 17:19:24 PM 8464
This Article Applies to: 

Este documento é adequado para o Omada Controller V4.1.5 ou superior. Para outras versões do Omada Controller, consulte a  FAQ 2609 .

Omada SDN Controller é um software usado para gerenciar o dispositivo TP-Link que suporta a plataforma SDN, incluindo EAP, Switch e Gateway. Ele suporta sistemas Windows e Linux. Este artigo apresentará como instalar o software no sistema Linux para você.

 

1. Faça backup da configuração e desinstale o controlador antigo.

Se você é a primeira vez que instala o Omada Controller, pode pular esta etapa. Se você estiver usando o Omada Controller e quiser atualizar seu controlador, faça backup da sua configuração primeiro.

Você pode seguir a seção Backup e restauração no Guia do usuário para fazer backup da configuração e restaurá-la após a atualização. O link abaixo contém o Guia do usuário do controlador de diferentes versões.

https://www.tp-link.com/en/support/download/omada-software-controller/

 

Faça backup da configuração do controlador antigo.

 

Reinicialize a configuração no controlador Omada SDN.

 

Após o backup da configuração, você pode desinstalar o antigo Omada Controller. A seguir está o comando de desinstalação.

sudo bash /opt/tplink/EAPController/uninstall.sh

Durante o processo de desinstalação, você pode optar por fazer backup dos dados originais de acordo com suas necessidades.

 

Nota:

O controlador SDN Omada suporta apenas para restaurar a configuração acima da versão 3.1.4. E algumas funções precisam ser reconfiguradas devido a alterações. Você pode consultar o guia de atualização .

 

2. Sistema de suporte

Omada SDN Controller suporta o seguinte sistema Linux. Verifique se o seu sistema pertence a um deles.

Ubuntu 14.04, 16.04, 18.04

CentOS 6.x, 7.x

Fedora 20 ou superior

Debian 8, 9

 

3. Exemplo de instalação para o sistema Ubuntu e CentOS

A seguir, usaremos o Ubuntu e o CentOS 7 como exemplos para mostrar o processo de instalação do Omada SDN Controller.

3.1 O exemplo para o Ubuntu e o pacote de instalação deb.

Para instalar e executar o controlador com sucesso, você pode instalar as dependências necessárias antes de instalar o controlador. O controlador precisa do  Java 8  e  MongoDB 3.0.15-3.6.18  para execução. Mas não há JRE e MongoDB integrados no pacote de instalação, portanto, você deve instalá-los sozinho. E também precisa instalar o jsvc e o curl para executar o controlador.

 

Instale o Java 8

Você pode usar o comando abaixo para instalar o Java 8.

sudo apt-get install –y openjdk-8-jre-headless

 

Você também pode consultar o link a seguir para instalar de outras maneiras.

https://www.oracle.com/java/technologies/javase/javase-jdk8-downloads.html

 

Instale o MongoDB

O controlador SDN Omada suporta o MongoDB 3.0.15-3.6.18. Você pode usar o comando “ apt list mongodb-org ” para verificar a versão padrão da fonte do MongoDB ou se você instalou o MongoDB.

 

Se você não instalou o MongoDB e a versão padrão é superior a 3.6.18, siga as etapas abaixo para instalar o MongoDB de uma versão adequada. Aqui vamos dar o exemplo da instalação da versão 3.4.

 

Use o comando abaixo para importar a chave GPG pública do MongoDB.

wget -qO - https://www.mongodb.org/static/pgp/server-3.4.asc | sudo apt-key add -

 

Crie /etc/apt/sources.list.d/mongodb-org-3.4.list com a versão apropriada do comando.

Ubuntu 14.04

eco "deb [arch = amd64] http://repo.mongodb.org/apt/ubuntu confiável / mongodb-org / 3.4 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-3.4.list

Ubuntu 16.04

eco "deb [arch = amd64, arm64] http://repo.mongodb.org/apt/ubuntu xenial / mongodb-org / 3.4 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-3.4.list

Ubuntu 18.04

echo "deb https://repo.mongodb.org/apt/ubuntu xenial / mongodb-org / 3.4 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-3.4.list

 

Emita o seguinte comando para recarregar o banco de dados do pacote local:

sudo apt-get update

 

Emita o seguinte comando para instalar o MongoDB:

sudo apt-get install -y mongodb-org

 

Você também pode seguir o tutorial oficial do MongoDB abaixo para instalar versões diferentes.

https://docs.mongodb.com/v3.4/tutorial/install-mongodb-on-ubuntu/

 

Instale o jsvc

sudo apt-get install jsvc

 

Instalar ondulação

sudo apt-get instalar ondulação

 

Instalar Omada SDN Controller

Por favor, vá ao  site oficial  da TP-Link para baixar o Controlador Omada, depois use o comando abaixo para instalar o controlador. Pode ser necessário alterar o diretório para a pasta em que você salva o pacote de instalação.

sudo dpkg –i omada_v4.1.5_linux_x64_20200703154636.deb

 

3.2 O exemplo para instalar o controlador no CentOS 7.

O CentOS não suporta o pacote de instalação deb. Por favor, instale com o pacote tar.gz.

Ainda precisamos instalar as dependências, incluindo Java 8, MongoDB, jsvc e curl.

 

Instale o Java 8

Verifique os pacotes de instalação disponíveis para o Java 8.

lista sudo yum java-1.8 *

Escolha a versão adequada para o seu sistema e instale o Java 8.

Instalação do sudo yum –y java-1.8.0-openjdk.x86_64

 

Você também pode consultar o link a seguir para instalar de outras maneiras.

https://www.oracle.com/java/technologies/javase/javase-jdk8-downloads.html

 

Instale o MongoDB

Aqui vamos dar o exemplo da instalação da versão 3.4.

Faça o download do pacote de instalação rpm do MongoDB.

sudo wget https://repo.mongodb.org/yum/redhat/7/mongodb-org/3.4/x86_64/RPMS/mongodb-org-server-3.4.24-1.el7.x86_64.rpm

 

Use o comando rpm para instalar o MongoDB.

sudo rpm -ivh mongodb-org-server-3.4.24-1.el7.x86_64.rpm

 

Instale o jsvc

instalação do sudo yum - y jsvc

 

Instalar ondulação

instalação do sudo yum –y curl

 

Instalar Omada SDN Controller

Por favor, vá ao  site oficial  da TP-Link para baixar o Controlador Omada, depois use o comando abaixo para descompactar o pacote de instalação. Pode ser necessário alterar o diretório para a pasta em que você salva o pacote de instalação.

tar zxvf Omada_Controller_v4.1.5_linux_x64_targz.tar.gz

Use o comando abaixo para instalar o Controller.

controlador: sudo bash ./install.sh

 

4. Execute o Omada Controller

Aqui estão alguns comandos que podem ajudá-lo a verificar / alterar o status do Omada Controller.

  • tpeap status - mostra o status do Controller;
  • tpeap start - inicia o controlador Omada;
  • tpeap stop - pare de executar o Omada Controller.

 

Depois de iniciar o Omada Controller, você pode navegar na URL  http: // localhost: 8088  ou https: // localhost: 8043 para acessar a página de gerenciamento da web do Controller.

 

 

Dicas:

  • Se o seu sistema Linux já instalou o MongoDB abaixo de 3.0.15, você pode seguir as etapas acima para instalar, o MongoDB será atualizado durante o processo de instalação. Se o seu sistema já instalou o MongoDB maior que 3.6.18, você deverá fazer o downgrade do MongoDB para a versão adequada.
  • Se o seu sistema Linux já instalou o Java inferior ao Java 8, você pode seguir as etapas acima para instalar, a versão antiga será substituída pelo Java 8. Se o seu sistema já instalou o Java superior ao Java 8, será necessário fazer o downgrade para o Java 8 por você mesmo.
  • O banco de dados de backup é usado apenas para restaurar quando você deseja fazer o downgrade para usar o controlador antigo. Não é recomendável importar o banco de dados de backup durante o controlador de instalação.

Se você encontrar o problema de dependência como o abaixo, poderá usar o comando “ sudo apt-get -f -y install ” ou “ apt --fix-all ” para corrigir o problema. Após corrigir o problema de dependência, o sistema continuará a instalação do controlador automaticamente.

InscriçãoA TP-Link leva a sério sua privacidade. Para mais informações sobre as práticas de privacidade da TP-Link, acesse Política de Privacidade da TP-Link.

From United States?

Check products and services for your region.