What can I do if Deco suddenly lost internet access?

If Something Goes Wrong
Updated 03-19-2020 02:20:41 AM
This Article Applies to: 

If Deco worked before but stop working suddenly, please refer to the corresponding suggestions to troubleshoot.

 

Main Deco stop working

1. Confirm the modem is working

Disconnect the main Deco from the modem, then connect a computer to the same Ethernet port on the modem with the same Ethernet cable. After that, check if internet is available on the PC.

If PC has no internet access, please contact your ISP or modem support.

 

2. Check the LED status on the main Deco

1.) LED is solid green

Please refer to the link to update firmware of the main Deco.

2.) LED is pulsing or solid red

Please disconnect the main Deco and the modem, turn off the modem and main Deco and then turn them back on, wait for 2 minutes, when the lights on the modem are steady, connect the main Deco back to the modem, then test internet connection.

3.) LED is pulsing blue

Please refer to the link to configure the main Deco again.

4.) LED is solid yellow or off

Please swap another power adapter or power socket.

 

3. Press the bottom reset button for one second to reset the main Deco if you haven’t tried reset the main Deco before, then refer to the link to configure the main Deco again. If you have tried reset the main Deco, please don’t reset it repeatedly.

 

Slave Deco stop working

1. Check the LED status on the slave Deco

1.) LED is solid green

Please refer to the link to update firmware of the slave Deco.

2.) LED is pulsing or solid red

Move the slave Deco to the side of the main Deco, turn off the main Deco and slave Deco and then turn them back on, wait for 2 minutes, then test internet connection with the slave Deco.

If still no internet access, press the bottom reset button for one second to reset the slave Deco, then refer to the link to configure the slave Deco again.

3.) LED is pulsing blue

Refer to the link to configure the slave Deco again.

4.) LED is solid yellow or off

Please swap another power adapter or power socket.

 

2. If you haven’t reset the slave Deco before. Please reset it first.

Find the reset button at the bottom of the Deco unit, press it for one second to start the reset process. Wait for about 2 minutes until the LED is pulsing blue, then refer to the link to configure the slave Deco again.

If you have reset the slave Deco before, just ignore this step.

 

A specific client has no internet access when connected to Deco, while other clients work fine with the Deco network.

1. Check if the client obtains an IP address. If not, reboot or reset the client.

2. Check if the client has been configured a static IP address. If so, change the client to obtain the IP address automatically.

3. Update the driver of the client’s wireless adapter.

4. Check if the client is included in a profile under Parental Control, which is paused or in bedtime.

If the problem remains, it’s suggested to contact the support of the client.

 

If above suggestions can’t solve your problem, it’s suggested to contact TP-Link support

SubscribeTP-Link takes your privacy seriously. For further details on TP-Link's privacy practices, see TP-Link's Privacy Policy.