如何管理不同地方的 EAP

使用者應用程式需求
更新10-30-2019 06:01:44 AM 32843
這篇文章適用於: 

 

適合對象: EAP Controller 2.0.3 或以上的版本,這邊使用 Controller 2.0.3 作為範例。

 

在 2.0.3 版本之前,EAP 控制器只能管理同一本地網路中的 EAP 設備,若您要在不同地方管理 EAP 設備,則需要每個地方都架設一台 EAP 控制器。

 

在更新 EAP 控制器到 2.0.3 或更高版本,以及 EAP 韌體 build 在 20150709 之後, 您將可從網際網路上藉由一個 EAP 控制器管理不同地點的 EAP(這又稱作 L3 管理).

 

下圖做為範例,EAP 控制器安裝在一台公共 IP 192.0.2.2 上的伺服器,在 Branch 1 有個 DHCP 伺服器,IP 池為 192.168.0.0/24;在 Branch 2 有個 IP 池為 192.168.1.0/24。

 

 

強烈建議您在要安裝 EAP 的位置運作 DHCP 伺服器,否則您必須分別設定每個 EAP 的 IP 位址,以避免 IP 衝突並在 EAP 控制器上進行相關設定,否則將無法進行管理。 

 

控制器條件

EAP 控制器升級至 2.0.3 以上版本。

確認防火牆未阻擋通訊埠 8088, 8043, 29810, 29811, 29812 和 29813,如果 EAP 控制器安裝在 NAT 路由器後面的電腦上,請確保為該電腦開啟了上述通訊埠。若使用 TP-Link 的路由器,可參考此FAQ;若為其他品牌,請聯繫他們的技術團隊。

 

EAP 方面的設定

在 EAP 端,需要在每個 EAP 設備中設定控制器 IP 位址(在上面的範例中為192.0.2.2),有兩個方式可設定控制器的 IP 位址。

 

方法 1. 透過 EAP Discover Utility 設定控制器 IP/域名

1. 從 TP-Link 網站上下載 EAP 控制器,在 Branch 1 的一台電腦安裝 EAP 控制器,電腦應與 EAP 在同個 IP 網段中。這邊以 PC1 為例。

2. 運作 EAP Discover Utility (若沒有變更安裝位址,您將會在 C:\Program Files (x86)\TP-Link\EAP Controller\bin 中找到)。所有在本地網路中的 EAP 設備將列於此。

 

3. 所有 EAP 的使用者名稱密碼預設都一樣,您可以使用 Batch Setting 一次對所有 EAP 設定控制器的 IP,若您的 EAP 設備使用者名稱和密碼都不同,您可以使用 manage 按鈕個別設定控制器的主機名稱/IP。

4. 等待直到狀態變為 Setting Succeed

 

5. EAPs 將在控制器中顯示為「pending」,表示等待採用「adopt」後進一步進行管理。

6. Branch 2 的 EAP 也使用相同的方法來設定。 

 

方法 2. 在 DHCP 伺服器上設定 option 138

 

EAP 設備可透過 DHCP Option 138 請求控制器的 IP。以 Branch 1 為例,假設 Branch 1 中的 DHCP 伺服器能設定不同的 DHCP 選項,在我們的範例中,將控制器的 IP 設定為 192.0.2.2 作為其 option 138 值。在啟動之後,本地網路中的所有 EAP 設備將能夠將 192.0.2.2 自動設為控制器的 IP。

 

如何在 DHCP 伺服器上設定 option 138,每個廠牌產品都不相同,故不在本篇討論範圍之內,請參考您的 DHCP 伺服器文件尋求支援。下列兩個範例可供參考。

 

Cisco IOS CLI:

ip dhcp pool test

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 8.8.8.8

option 138 ip 192.0.2.2

更多細節請參考 Cisco 網站

 

MikroTik RouterOS CLI:

#Assume you have already setup a dhcp server with item number 0

#0xC0000002 equeals 192.0.0.2

/ip dhcp-server option add code=138 name=controller value=0xC0000002

/ip dhcp-server network set 0 dhcp-option=controller

更多細節請參考 MikroTik 手冊

訂閱TP-Link認真對待您的隱私。 有關TP-Link隱私慣例的更多詳細信息,請參閱TP-Link的隱私政策

From United States?

Check products and services for your region.