Linux 시스템에 Omoada SDN 컨트롤러를 설치하는 방법 (Controller 4.1.5 이상)

설정 가이드
수정일08-14-2020 10:50:05 AM 23378
본 내용은 다음 항목에 적용됩니다: 

이 문서는 Omada Controller V4.1.5 이상에 적합합니다. 다른 Omada 컨트롤러 버전은  FAQ 2609 를 참조하세요.

Omada SDN 컨트롤러는 SDN 플랫폼을 지원하는 TP-Link 장치를 관리하는 데 사용되는 소프트웨어로 EAP, 스위치 및 게이트웨이를 포함합니다. Windows 및 Linux 시스템을 모두 지원합니다. 이 기사에서는 Linux 시스템에 소프트웨어를 설치하는 방법을 소개합니다.

 

1. 구성을 백업하고 이전 컨트롤러를 제거합니다.

Omada 컨트롤러를 처음 설치하는 경우 이 단계를 건너 뛸 수 있습니다. Omada 컨트롤러를 사용 중이고 컨트롤러를 업그레이드 하려면 먼저 구성을 백업하십시오.

사용자 가이드의 백업 및 복원 섹션에 따라 구성을 백업하고 업그레이드 후 복원 할 수 있습니다. 아래 링크에는 다양한 버전의 컨트롤러 사용 설명서가 포함되어 있습니다.

https://www.tp-link.com/en/support/download/omada-software-controller/

 

이전 컨트롤러의 구성을 백업하십시오.

 

Omada SDN 컨트롤러에서 구성을 복원합니다.

 

구성을 백업 한 후 이전 Omada 컨트롤러를 제거 할 수 있습니다. 다음은 제거 명령입니다.

sudo bash /opt/tplink/EAPController/uninstall.sh

제거 프로세스 중에 필요에 따라 원본 데이터를 백업할지 여부를 선택할 수 있습니다.

 

노트 :

Omada SDN 컨트롤러는 버전 3.1.4 이상의 구성 복원 만 지원합니다. 그리고 일부 기능은 변경으로 인해 재구성해야합니다. 업그레이드 가이드를 참조하세요.

 

2. 지원 시스템

Omada SDN 컨트롤러는 다음 Linux 시스템을 지원합니다. 시스템이 이들 중 하나에 속하는지 확인하십시오.

Ubuntu 14.04, 16.04, 18.04

CentOS 6.x, 7.x

Fedora 20 혹은 이상

Debian 8, 9

 

3. Ubuntu 및 CentOS 시스템 설치 예

다음으로 Ubuntu 및 CentOS 7을 예로 들어 Omada SDN 컨트롤러의 설치 프로세스를 보여줍니다.

3.1 Ubuntu 및 deb 설치 패키지의 예.

컨트롤러를 성공적으로 설치하고 실행하려면 컨트롤러를 설치하기 전에 필요한 종속성을 설치할 수 있습니다. 컨트롤러를 실행하려면 Java 8MongoDB 3.0.15-3.6.18이 필요합니다. 하지만 설치 패키지에 내장 된 JRE 및 MongoDB가 없으므로 직접 설치해야합니다. 또한 컨트롤러 실행을 위해 jsvccurl을 설치해야합니다.

 

Java 8 설치

아래 명령을 사용하여 Java 8을 설치할 수 있습니다.

sudo apt-get install –y openjdk-8-jre-headless

 

다음 링크를 참조하여 다른 방법으로 설치할 수도 있습니다.

https://www.oracle.com/java/technologies/javase/javase-jdk8-downloads.html

 

MongoDB 설치

Omada SDN 컨트롤러는 MongoDB 3.0.15-3.6.18을 지원합니다. "apt list mongodb-org"명령을 사용하여 MongoDB 소스의 기본 버전 또는 MongoDB를 설치했는지 여부를 확인할 수 있습니다.

 

MongoDB를 설치하지 않았고 기본 버전이 3.6.18보다 높은 경우 아래 단계에 따라 적절한 버전의 MongoDB를 설치할 수 있습니다. 여기에서는 버전 3.4를 설치하는 예를 들었습니다.

 

아래 명령을 사용하여 MongoDB 공개 GPG 키를 가져옵니다.

wget -qO - https://www.mongodb.org/static/pgp/server-3.4.asc | sudo apt-key add -

 

적절한 버전의 명령을 사용하여 /etc/apt/sources.list.d/mongodb-org-3.4.list를 만듭니다.

Ubuntu 14.04

echo "deb [ arch=amd64 ] http://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.4 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-3.4.list

Ubuntu 16.04

echo "deb [ arch=amd64,arm64 ] http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.4 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-3.4.list

Ubuntu 18.04

echo "deb https://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.4 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-3.4.list

 

다음 명령을 실행하여 로컬 패키지 데이터베이스를 다시 로드하십시오.

sudo apt-get update

 

다음 명령을 실행하여 MongoDB를 설치하십시오.

sudo apt-get install -y mongodb-org

 

아래의 MongoDB 공식 자습서에 따라 다른 버전을 설치할 수도 있습니다.

https://docs.mongodb.com/v3.4/tutorial/install-mongodb-on-ubuntu/

 

jsvc 설치

sudo apt-get install jsvc

 

curl 설치

sudo apt-get install curl

 

Omada SDN 컨트롤러 설치

TP-Link  공식 웹 사이트에서 Omada 컨트롤러를 다운로드 한 후 아래 명령을 사용하여 컨트롤러를 설치하세요. 디렉토리를 설치 패키지를 저장 한 폴더로 변경해야 할 수 있습니다.

sudo dpkg –i omada_v4.1.5_linux_x64_20200703154636.deb

 

3.2 CentOS 7에 컨트롤러를 설치하는 예

CentOS는 deb 설치 패키지를 지원하지 않습니다. tar.gz 패키지로 설치하세요.

Java 8, MongoDB, jsvc 및 curl을 포함한 종속성을 여전히 설치해야합니다.

 

Java 8 설치

Java 8에 사용 가능한 설치 패키지를 확인하십시오.

sudo yum list java-1.8*

시스템에 적합한 버전을 선택하고 Java 8을 설치하십시오.

sudo yum install –y java-1.8.0-openjdk.x86_64

 

다음 링크를 참조하여 다른 방법으로 설치할 수도 있습니다.

https://www.oracle.com/java/technologies/javase/javase-jdk8-downloads.html

 

MongoDB 설치

여기에서는 버전 3.4를 설치하는 예를 들었습니다.

MongoDB의 rpm 설치 패키지를 다운로드합니다.

sudo wget https://repo.mongodb.org/yum/redhat/7/mongodb-org/3.4/x86_64/RPMS/mongodb-org-server-3.4.24-1.el7.x86_64.rpm

 

rpm 명령을 사용하여 MongoDB를 설치하십시오.

sudo rpm -ivh mongodb-org-server-3.4.24-1.el7.x86_64.rpm

 

jsvc 설치

sudo yum install –y jsvc

 

curl 설치

sudo yum install –y curl

 

Omada SDN 컨트롤러 설치

Omada 컨트롤러를 다운로드하려면 TP-Link의 공식 웹 사이트로 이동하세요. 그런 다음 터미널을 실행하고 디렉토리를 설치 패키지를 저장 한 폴더로 변경합니다. 아래 명령어를 사용하여 설치 패키지의 압축을 풉니다.

tar zxvf Omada_Controller_v4.1.5_linux_x64.tar.gz

아래 명령을 사용하여 압축이 풀린 폴더로 들어갑니다.

cd Omada_Controller_v4.1.5_linux_x64

아래 명령을 사용하여 Controller를 설치하십시오.

sudo bash install.sh

 

4. Omada 실행

다음은 Omada 컨트롤러의 상태를 확인 / 변경하는 데 도움이되는 몇 가지 명령입니다.

  • tpeap status   --  컨트롤러의 상태를 표시합니다.
  • tpeap start     --  Omada 컨트롤러를 시작합니다.;
  • tpeap stop     --  Omada 컨트롤러 실행을 중지합니다.

 

Omada 컨트롤러를 시작한 후 URL http://localhost:8088 또는 http://localhost:8043을 찾아 컨트롤러의 웹 관리 페이지에 액세스 할 수 있습니다.

 

 

팁 :

  • Linux 시스템에 이미 3.0.15 미만의 MongoDB가 설치되어있는 경우 위 단계에 따라 설치하면 MongoDB가 설치 프로세스 중에 업그레이드됩니다. 시스템에 이미 3.6.18보다 높은 MongoDB가 설치되어있는 경우 MongoDB를 적절한 버전으로 직접 다운 그레이드해야합니다.
  • Linux 시스템에 Java 8보다 낮은 Java가 이미 설치되어있는 경우 위 단계에 따라 설치하면 Java 8이 이전 버전을 덮어 씁니다. 시스템에 Java 8보다 높은 Java가 이미 설치되어있는 경우 Java 8로 다운 그레이드해야합니다. 혼자서.
  • 백업 데이터베이스는 이전 컨트롤러를 사용하기 위해 다운 그레이드하려는 경우에만 복원하는 데 사용됩니다. 컨트롤러를 설치하는 동안 백업 데이터베이스를 가져 오는 것은 권장되지 않습니다.

아래와 같은 종속성 문제가 발생하면“sudo apt-get -f -y install”또는“apt --fix-all”명령을 사용하여 문제를 해결할 수 있습니다. 종속성 문제를 해결 한 후 시스템은 컨트롤러 설치를 자동으로 완료합니다.

구독TP-Link는 귀하의 개인 정보 보호를 중요하게 생각합니다. TP-Link의 개인 정보 보호에 대한 자세한 내용은, TP-Link의 개인 정보 보호 정책을 참조하십시오.

From United States?

해당 지역의 제품, 이벤트 및 서비스를 받아보세요.