Comment installer le contrôleur Omada SDN sur un système Linux (ci-dessus Controller 4.1.5)

Guide de Configuration
Mis à jour 08-04-2020 09:10:27 AM
Ce document concerne les modèles suivants : 

Ce document convient à Omada Controller V4.1.5 ou supérieur. Pour les autres versions du contrôleur Omada, veuillez consulter la  FAQ 2096 .

Omada SDN Controller est un logiciel utilisé pour gérer le périphérique TP-Link prenant en charge la plate-forme SDN, notamment EAP, Switch et Gateway. Il prend en charge les systèmes Windows et Linux. Cet article vous présentera comment installer le logiciel sur le système Linux.

 

1. Sauvegardez la configuration et désinstallez l'ancien contrôleur.

Si vous installez Omada Controller pour la première fois, vous pouvez ignorer cette étape. Si vous utilisez Omada Controller et souhaitez mettre à niveau votre contrôleur, veuillez d'abord sauvegarder votre configuration.

Vous pouvez suivre la section Sauvegarde et restauration du Guide de l'utilisateur pour sauvegarder la configuration et la restaurer après la mise à niveau. Le lien ci-dessous contient le guide de l'utilisateur du contrôleur de différentes versions.

https://www.tp-link.com/en/support/download/omada-software-controller/

 

Sauvegardez la configuration de l'ancien contrôleur.

 

Rétablissez la configuration sur le contrôleur Omada SDN.

 

 

Après avoir sauvegardé la configuration, vous pouvez désinstaller l'ancien contrôleur Omada. Voici la commande de désinstallation.

sudo bash /opt/tplink/EAPController/uninstall.sh

Pendant le processus de désinstallation, vous pouvez choisir de sauvegarder les données d'origine en fonction de vos besoins.

 

Note:

Le contrôleur Omada SDN prend uniquement en charge la restauration de la configuration ci-dessus version 3.1.4. Et certaines fonctions doivent être reconfigurées en raison de changements. Vous pouvez vous référer au guide de mise à niveau .

 

2. Système de soutien

Omada SDN Controller prend en charge le système Linux suivant. Assurez-vous que votre système appartient à l'un d'entre eux.

Ubuntu 14.04, 16.04, 18.04

CentOS 6.x, 7.x

Fedora 20 ou supérieur

Debian 8, 9

 

3. Exemple d'installation pour les systèmes Ubuntu et CentOS

Ensuite, nous prendrons Ubuntu et CentOS 7 comme exemples pour montrer le processus d'installation du contrôleur Omada SDN.

 

3.1 L'exemple pour Ubuntu et le package d'installation deb.

 

Pour installer et exécuter correctement le contrôleur, vous pouvez installer les dépendances requises avant d'installer le contrôleur. Le contrôleur a besoin de  Java 8  et  MongoDB 3.0.15-3.6.18  pour fonctionner. Mais il n'y a pas de JRE et MongoDB intégrés dans le package d'installation, vous devez donc les installer vous-même. Et aussi besoin d'installer jsvc et curl pour exécuter le contrôleur.

 

Installez Java 8

Vous pouvez utiliser la commande ci-dessous pour installer Java 8.

sudo apt-get install –y openjdk-8-jre-headless

 

Vous pouvez également vous référer au lien suivant pour installer d'autres manières.

https://www.oracle.com/java/technologies/javase/javase-jdk8-downloads.html

 

Installez MongoDB

Le contrôleur Omada SDN prend en charge MongoDB 3.0.15-3.6.18. Vous pouvez utiliser la commande « apt list mongodb-org » pour vérifier la version par défaut de la source MongoDB ou si vous avez installé MongoDB.

 

Si vous n'avez pas installé MongoDB et que la version par défaut est supérieure à 3.6.18, vous pouvez suivre les étapes ci-dessous pour installer MongoDB d'une version appropriée. Nous prenons ici l'exemple de l'installation de la version 3.4.

 

Utilisez la commande ci-dessous pour importer la clé GPG publique MongoDB.

wget -qO - https://www.mongodb.org/static/pgp/server-3.4.asc | sudo apt-key ajouter -

 

Créez /etc/apt/sources.list.d/mongodb-org-3.4.list avec la version appropriée de la commande.

Ubuntu 14.04

echo "deb [arch = amd64] http://repo.mongodb.org/apt/ubuntu trusty / mongodb-org / 3.4 multivers" | sudo tee /etc/apt/sources.list.d/mongodb-org-3.4.list

Ubuntu 16.04

echo "deb [arch = amd64, arm64] http://repo.mongodb.org/apt/ubuntu xenial / mongodb-org / 3.4 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-3.4.list

Ubuntu 18.04

echo "deb https://repo.mongodb.org/apt/ubuntu xenial / mongodb-org / 3.4 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-3.4.list

 

Exécutez la commande suivante pour recharger la base de données de packages locale:

sudo apt-get mise à jour

 

Exécutez la commande suivante pour installer MongoDB:

sudo apt-get install -y mongodb-org

 

Vous pouvez également suivre le tutoriel officiel MongoDB ci-dessous pour installer différentes versions.

https://docs.mongodb.com/v3.4/tutorial/install-mongodb-on-ubuntu/

 

Installez jsvc

sudo apt-get install jsvc

 

Installer curl

sudo apt-get install curl

 

Installez Omada SDN Controller

Veuillez vous rendre sur le  site officiel  de TP-Link pour télécharger le contrôleur Omada, puis utilisez la commande ci-dessous pour installer le contrôleur. Vous devrez peut-être modifier le répertoire dans le dossier dans lequel vous enregistrez le package d'installation.

sudo dpkg –i omada_v4.1.5_linux_x64_20200703154636.deb

 

3.2 L'exemple d'installation du contrôleur sur CentOS 7.

CentOS ne prend pas en charge le package d'installation deb. Veuillez installer avec le package tar.gz.

Nous devons encore installer les dépendances, notamment Java 8, MongoDB, jsvc et curl.

 

Installez Java 8

Vérifiez les packages d'installation disponibles pour Java 8.

sudo yum list java-1.8 *

 

Choisissez la version adaptée à votre système et installez Java 8.

sudo yum install –y java-1.8.0-openjdk.x86_64

 

Vous pouvez également vous référer au lien suivant pour installer d'autres manières.

https://www.oracle.com/java/technologies/javase/javase-jdk8-downloads.html

 

Installez MongoDB

Nous prenons ici l'exemple de l'installation de la version 3.4.

Téléchargez le package d'installation rpm de MongoDB.

sudo wget https://repo.mongodb.org/yum/redhat/7/mongodb-org/3.4/x86_64/RPMS/mongodb-org-server-3.4.24-1.el7.x86_64.rpm

 

Utilisez la commande rpm pour installer MongoDB.

sudo rpm -ivh mongodb-org-server-3.4.24-1.el7.x86_64.rpm

 

Installez jsvc

sudo yum install –y jsvc

 

Installer curl

sudo yum install –y curl

 

Installez Omada SDN Controller

Veuillez vous rendre sur le  site officiel  de TP-Link pour télécharger le contrôleur Omada, puis utilisez la commande ci-dessous pour décompresser le package d'installation. Vous devrez peut-être modifier le répertoire dans le dossier dans lequel vous enregistrez le package d'installation.

tar zxvf Omada_Controller_v4.1.5_linux_x64_targz.tar.gz

Utilisez la commande ci-dessous pour installer Controller.

contrôleur : sudo bash ./install.sh

 

4. Exécutez le contrôleur Omada

Voici quelques commandes qui peuvent vous aider à vérifier / modifier l'état du contrôleur Omada.

  • tpeap status - affiche l'état du contrôleur;
  • tpeap start - lance le contrôleur Omada;
  • tpeap stop - arrête d'exécuter le contrôleur Omada.

 

Après avoir démarré le contrôleur Omada, vous pouvez parcourir l'URL  http: // localhost: 8088  ou https: // localhost: 8043 pour accéder à la page de gestion Web du contrôleur.

 

Conseils:

  • Si votre système Linux a déjà installé MongoDB inférieur à 3.0.15, vous pouvez suivre les étapes ci-dessus pour l'installer, MongoDB sera mis à niveau pendant le processus d'installation. Si votre système a déjà installé MongoDB supérieur à 3.6.18, vous devez vous-même rétrograder MongoDB vers la version appropriée.
  • Si votre système Linux a déjà installé Java inférieur à Java 8, vous pouvez suivre les étapes ci-dessus pour installer, l'ancienne version sera écrasée par Java 8. Si votre système a déjà installé Java supérieur à Java 8, vous devez revenir à Java 8 par toi-même.
  • La base de données de sauvegarde n'est utilisée pour la restauration que lorsque vous souhaitez rétrograder pour utiliser l'ancien contrôleur. Il n'est pas recommandé d'importer la base de données de sauvegarde pendant l'installation du contrôleur.

Si vous rencontrez le problème de dépendance comme ci-dessous, vous pouvez utiliser la commande «sudo apt-get -f -y install» ou «apt –fix-all» pour résoudre le problème. Après avoir résolu le problème de dépendance, le système continuera à terminer l'installation du contrôleur automatiquement.

 

 

Newsletter TP-LinkTP-Link prend votre vie privée au sérieux. Pour plus de détails sur la politique de confidentialité de TP-Link, veuillez consultez la page suivante Politique de confidentialité de TP-Link .

From United States (English)?

Check products and services for your region.