How to do troubleshooting from the system log when PPPoE connection fails?

This FAQ is for the users who have a DSL bridge modem with PPPoE service and need to do PPPoE connection on the TP-link router. If you are using Cable Modem, please ignore the article.

 

The PPPoE connection includes two phases: PPPoE Discovery phase and PPPoE Session phase. There are four steps to the Discovery stage: PADI, PADO, PADR, PADS and three steps to the Session stage: LCP, Authentication(includes two types: CHAP and PAP) and IPCP.

 

The three cases below are about how to read the system log of the router to find out why the PPPoE connection fails.

 

Case 1.

If the PPPoE connection is successful, it will get through the PPP Discovery phase and Session phase, then shows PPPoE connected.

The the system log is as below:


Case 2.

If the username or password is incorrect, it can get through the PPP Discovery stage, but in the PPP Session stage, there would be an error message: Failed to authenticate ourselves to peer. In this case, you need to check the username and password with your Internet service Provider.

The system log is as below:


Case 3.

If the WAN port is unplugged, it cannot get through the PPP Discovery Stage. It repeats sending PADI packets, but never succeeds. In this case, you need to check whether you have correctly plugged your modem into the WAN(Internet) port of the router.

The system log is as below:


Note:

You need to log in the router’s web management page, go to “System Tools→System Log” to read/save the log. If you do not know how to log in the web management page, please refer to FAQ 87.

 

This Article Applies to:
TL-WR841N , TL-WDR3500 , TL-WR743ND
User Application Requirement | Updated 11-28-2014 10:07:08 AM